Wallpaper Script Forum » How-To and Troubleshooting

Wallpaperscript installed XAMPP Localhost

(5 posts)
  1. I'm at a stand still. I enabled zend optimizer on my php.ini and have everything else set up but the installation script wont allow me to install and connect with my mysql with no password and my username is 'root'. Telling me that I have an "invalid database password".

    What am I supposed to do to get this to function on my localhost?

    Thx
    Mike52

    Posted 3 years ago #
  2. Ha!
    I figured it out. I ended up giving my database a password.

    These are the steps I took in doing so:

    Little-tough way of resetting the ‘root’ user password in MySQL:

    1. Start the Apache Server and MySQL instances from the XAMPP control panel.
    2. After the server started, open any web browser and give http://localhost:8090/phpmyadmin/ (if you are running XAMPP on 8090 port). This will open the phpMyAdmin interface. Using this interface we can manager the MySQL server from the web browser.
    3. In the phpMyAdmin window, select SQL tab from the right panel. This will open the SQL tab where we can run the SQL queries.
    4. Now type the following query in the textarea and click Go
    UPDATE mysql.user SET Password=PASSWORD('password') WHERE User='root';
    FLUSH PRIVILEGES;
    5. Now you will see a message saying that the query has been executed successfully.
    6. If you refresh the page, you will be getting a error message. This is because the phpMyAdmin configuration file is not aware of our newly set root passoword. To do this we have to modify the phpMyAdmin config file.

    Modifying phpMyAdmin config file:

    1. Open the file [XAMPP Installation Path] / phpmyadmin / config.inc.php in your favorite text editor.
    2. Search for the string $cfg['Servers'][$i]['password'] = ”; and change it to like this, $cfg['Servers'][$i]['password'] = ‘password’; Here the ‘password’ is what we set to the ‘root’ user using the SQL query.
    3. Now all set to go. Save the config.inc.php file and restart the XAMPP server.

    Here is the original link:
    http://veerasundar.com/blog/2009/01/how-to-change-the-root-password-for-mysql-in-xampp/

    I hope this helps anyone else that is using XAMPP for Wallpaperscript.

    Mike52 =)

    Posted 3 years ago #
  3. hey how to install zend on wamp ?

    Posted 3 years ago #
  4. I'm not familiar with wamp. But you have to enable zend optimizer in your php.ini file.

    For XAMPP not sure for WAMP:

    XAMPP comes with Zend Optimizer pre installed you just need to enable it. This can be done easily by changing only one character in a line in php.ini.

    To fix this issue and turn on zend optimizer for xampp, simply:

    1. turn off your xampp (apache) server

    2. goto: xampp > php > php.ini

    3. find the line:

    zend_optimizer.enable_loader = 0

    and change the value from 0 to 1 like this:

    zend_optimizer.enable_loader = 1

    Note: in some versions of xampp, the line is already uncommented or turned to 1.

    4. Turn on the apache server and test your script

    Posted 3 years ago #
  5. its okay,

    thanks

    Posted 3 years ago #

RSS feed for this topic

Reply

You must log in to post.